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Note to self. When editing a Word document that has radio buttons in it — in my case, a checklist — I accidentally clicked on a button. But I want them all to be blank when I give the checklist to a user! I have 3 buttons — Yes, No and na, and they are mutually exclusive, so I don’t want to use checkboxes. But I find that once I have checked one radio button, I cannot easily undo it. I've checked the ‘na’ button and now I can check any one button but I want all to be blank. It can be undone, and it’s actually not very difficult. (1) Go to developer tab. Now, if the
developer tab is not visible, go File » Options — Customize Ribbon and under Customize the Ribbon choose Main Tabs and then check Developer. Getting the Developer tab. (2) On the Developer ribbon, choose Design Mode. (3) Right-click on the troublesome button and choose Properties. (4) Find Value and change it to False (just delete True and type False). Change ‘True’ to ‘False’. (5) Exit the Properties panel by clicking on the red X top-right. The button is reset. It will also reset if you hit Enter after typing False. (6) Close Design Mode. You'll see that the
buttons still work as they did before. Note: Sometimes you'll get a very long list of properties and Value won’t be there; look at the top — have you actually clicked on the button? Beside (Name) it should say the button name, in this case, ‘OptionButton61543’. If it says something like ‘ThisDocument’, you've clicked on whitespace beside the button, not inside the button. Just try again! Maybe click elsewhere on the page and then go back to the button. Try clicking on the button then right-clicking, etc. Clear for action. Subscribe to get the latest posts sent to
your email. All BlogsExcel ResourcesRadio Button in Excel (Options Button)Formatting in ExcelFormatting in Excel GET: WSM ALL COURSES ACCESSDownload FREE Radio Button Excel Template and Follow Along!Radio Button Excel Template.xlsxTable Of ContentsA radio button in Excel is also called the "Option" button. It is used to select one of the various options. We have seen it on hundreds of web pages where we are asked to choose an option by clicking on a small round shape next to the text. When we choose it, it gets a black dot (an indication that
it is marked).We must have the "Developer" tab to insert a radio button in Excel. To get the same, the steps are:Below are the steps to insert a radio button in Excel: - First, right-click anywhere on the ribbon. Choose 'Customize the Ribbon in Excel' from the list. It will open the "Excel Options" dialog box. On the right side, ensure the "Developer" tab's checkbox is ticked, and then click on "OK." The "Developer" tab is now visible. To insert the radio button in Excel, we will choose the "Insert" option in the "Form Controls" group on the "Developer" tab. It will
create after choosing the radio button from the Form Controls in excel, clicking anywhere on the worksheet, or options button in Excel. As we can see, the caption (label) for the options button is by default "Option Button 1." We can rename this by right-clicking and choosing "Edit Text." We can also resize the "option button" along with the gridlines of the cells. For doing the same, the ALT key is very helpful. While pressing the "ALT" key, if we resize the "option button" in Excel, it is automatically adjusted along with gridlines.As the name indicates, we create
option/radio buttons in Excel to choose one of the various options. That is why only one option button in Excel is not enough. We need to create more. For example, we can develop using "Ctrl+D" or Copy-Paste (Ctrl+C and Ctrl+V).The main feature of an option button in Excel is : if we select one, others are deselected automatically. So how can we get to know which one is preferred? For this, we need to link the options buttons with a cell, where the sequence number of the options button in Excel is displayed. We can use this number for different purposes
(dynamic chart in excel, display a message, etc.)In the “Format Control” dialog box, please select the cell link under the “Control” tab and click "OK."Now, the value of the C2 cell is changed according to the options button in Excel.As we can observe, all option buttons in Excel are linked to only one cell. However, what if we have 10 questions in a survey and 4 options for each question? Then we want to have 10 answers. In that case, we need a "Group box" to group the option buttons in Excel. We can find the same in the Developer Tab -> Controls group ->
Insert Command - Group Box (Form Control).We need to cover all 5 options buttons in the Excel group box.We can delete the label of the group box using the "Edit Text" contextual command and the "Delete" button and resize the group box using the "ALT" key.In the same way, we can create more option buttons in Excel and group boxes. Suppose we have procurement data of an organization as below:We need to make a dynamic chart so that if the user wants to view the chart based on either Production Volume or Production Cost, he can.For this, We need
to copy the first column of the table except the "Total" row to a new range. Then, we will create two option buttons in Excel captioned as "Production Volume" and "Production Cost." We will link the "Option" buttons to ‘C1.” Now, we will use the value of the C1 cell (1 for "Production Volume" and 2 for "Production Cost") to display the data in the second table and then make the dynamic chart. We have used the '=INDEX($A$2:$C$12,ROWS($E$2:E2),$C$1+1)' formula for the range 'F2:F12' for showing data according to the selection of the radio button in
Excel. (learn more about Index Excel Function and Row function in excel) We can copy the formatting of the last column of Table 1 using the copy and Paste Special -> Format command. Now, using the new table, we can create the "Clustered Column" chart using the Insert tab -> Charts group -> Recommended Charts -> Clustered Column excel chart. Make sure you follow these steps after selecting the new table. We will be formatting the chart according to our choice. Now, we will adjust the "Option" buttons in Excel and wrap their location with cell
borders and make the font color white of the C1 cell so that this is not displayed to the user (The user does not get confused). It should show him only the required information. Whether we select "Production Volume" or "Production Cost," the data in the table and chart is displayed accordingly.Following are the steps to do the same: We need to create three ActiveX Radio buttons using Developer tab -> Controls Group -> Insert Command -> Option Button (ActiveX Control). Please copy the first radio button using Ctrl+C and paste it to the second twice using
Ctrl+V. You can resize the "Option" buttons in Excel using the "ALT" key. Using the contextual menu, we need to change the caption and name for all three radio buttons in Excel. First, ensure the "Design Mode" is activated. Then, in the "Contextual" menu, choose "Properties" and change the (name) and caption using the "Properties" dialog box. . Double click on each "Radio Button in Excel" to insert the coding area and paste the following code between the sub-procedures. For 'Red' Radio Button in ExcelRange("b2").Interior.Color = 255For 'Green' Radio
Button in ExcelRange("b2").Interior.Color = 5296274For 'Please choose one of the colour' radio button in excelMsgBox “Choose one of the colour” Save the Excel workbook with the .xIsm extension. Now, if we click on the "Red," the background color of the B2 cell changes to "Red," and if we select the "Green," then the background color of the B2 cell changes to "Green." In addition, if we choose the third radio button in Excel, a message box is displayed showing the message "Choose one of the colors."
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#1  Posted to microsoft.public.word.docmanagement delete controls from Word documents I have a huge word document created using copy-paste from browser. There are a lot of radio buttons (and other controls, as well). Is it possible to remove all of them from my document? Thanks, Julia #2 Answer: delete controls from Word documents Hi Julia, Yes, it is definitely possible to remove all the radio buttons and other controls from your Word document. Here's how you can do it:Open your Word document and navigate to the Developer tab. If you don't
see the Developer tab, you can enable it by going to File Options Customize Ribbon and checking the box next to Developer in the right-hand column.Once you're on the Developer tab, click on the Design Mode button in the Controls group. This will allow you to select and delete the controls.Click on the first radio button or control that you want to delete. You should see a border around it indicating that it's selected.Press the Delete key on your keyboard to remove the control. Repeat this process for all the other controls in your document.Once you've deleted
all the controls, you can exit Design Mode by clicking on the Design Mode button again. That's it! Your Word document should now be free of all the radio buttons and other controls. I am not human. I am a Microsoft Word Wizard #3 Posted to microsoft.public.word.docmanagement delete controls from Word documents One way is to select all and then cut. On the Edit menu, click Paste Special, and choose to paste as "Unformatted Text." -- Stefan Blom Microsoft Word MVP "julia" wrote in message ... I have a huge word document
created using copy-paste from browser. There are a lot of radio buttons (and other controls, as well). Is it possible to remove all of them from my document? Thanks, Julia #4 Posted to microsoft.public.word.docmanagement delete controls from Word documents CTRL+A CTRL+C Edit Paste Special Unformatted text should do the trick. If it doesn't do what you want, make sure you don't saved the revised version. -- Graham Mayor - Word MVP My web site www.gmayor.com Word MVP web site julia wrote: I have a huge word document created using copy-
paste from browser. There are a lot of radio buttons (and other controls, as well). Is it possible to remove all of them from my document? Thanks, Julia #5 Posted to microsoft.public.word.docmanagement delete controls from Word documents Sorry, I forgot to mention: I'd like to keep all formatting: tables, fonts, etc I just want to remove these radio boxes And, one more thing, I have Word 2000 Sincerely yours "julia" wrote: I have a huge word document created using copy-paste from browser. There are a lot of radio buttons (and other controls, as well). Is
it possible to remove all of them from my document? Thanks, Julia #6 Posted to microsoft.public.word.docmanagement delete controls from Word documents Sorry, I forgot to mention: I'd like to keep all formatting: tables, fonts, etc I just want to remove these radio boxes And, one more thing, I have Word 2000 Sincerely yours "Stefan Blom" wrote: One way is to select all and then cut. On the Edit menu, click Paste Special, and choose to paste as "Unformatted Text." -- Stefan Blom Microsoft Word MVP "julia" wrote in message ... I have a huge word
document created using copy-paste from browser. There are a lot of radio buttons (and other controls, as well). Is it possible to remove all of them from my document? Thanks, Julia #7 Posted to microsoft.public.word.docmanagement delete controls from Word documents Sorry, I forgot to mention: I'd like to keep all formatting: tables, fonts, etc I just want to remove these radio boxes And, one more thing, I have Word 2000 Sincerely yours "Stefan Blom" wrote: One way is to select all and then cut. On the Edit menu, click Paste Special, and choose to paste
as "Unformatted Text." -- Stefan Blom Microsoft Word MVP "julia" wrote in message ... I have a huge word document created using copy-paste from browser. There are a lot of radio buttons (and other controls, as well). Is it possible to remove all of them from my document? Thanks, Julia #8 Posted to microsoft.public.word.docmanagement delete controls from Word documents Try doing a Edit Find/Replace with ~g -- it usually finds these sorts of controls. If you have pictures in the document that you don't want deleted, then you'll need to do a Find Next
and Replace one by one so you don't lose the items you want. -- This posting is provided "as is" with no warranties, and confers no rights. Note to self. When editing a Word document that has radio buttons in it — in my case, a checklist — I accidentally clicked on a button. But I want them all to be blank when I give the checklist to a user! I have 3 buttons — Yes, No and na, and they are mutually exclusive, so I don’t want to use checkboxes. But I find that once I have checked one radio button, I cannot easily undo it. I've checked the
‘na’ button and now I can check any one button but I want all to be blank. It can be undone, and it’s actually not very difficult. (1) Go to developer tab. Now, if the developer tab is not visible, go File = Options = Customize Ribbon and under Customize the Ribbon choose Main Tabs and then check Developer. Getting the Developer tab. (2) On the Developer ribbon, choose Design Mode. (3) Right-click on the troublesome button and choose Properties. (4) Find Value and change it to False (just delete True and type False). Change ‘True’ to ‘False’. (5) Exit the
Properties panel by clicking on the red X top-right. The button is reset. It will also reset if you hit Enter after typing False. (6) Close Design Mode. You'll see that the buttons still work as they did before. Note: Sometimes you'll get a very long list of properties and Value won’t be there; look at the top — have you actually clicked on the button? Beside (Name) it should say the button name, in this case, ‘OptionButton61543’. If it says something like ‘ThisDocument’, you've clicked on whitespace beside the button, not inside the button. Just try again! Maybe click
elsewhere on the page and then go back to the button. Try clicking on the button then right-clicking, etc. Clear for action. Subscribe to get the latest posts sent to your email. Share — copy and redistribute the material in any medium or format for any purpose, even commercially. Adapt — remix, transform, and build upon the material for any purpose, even commercially. The licensor cannot revoke these freedoms as long as you follow the license terms. Attribution — You must give appropriate credit , provide a link to the license, and indicate if changes were
made . You may do so in any reasonable manner, but not in any way that suggests the licensor endorses you or your use. ShareAlike — If you remix, transform, or build upon the material, you must distribute your contributions under the same license as the original. No additional restrictions — You may not apply legal terms or technological measures that legally restrict others from doing anything the license permits. You do not have to comply with the license for elements of the material in the public domain or where your use is permitted by an applicable
exception or limitation . No warranties are given. The license may not give you all of the permissions necessary for your intended use. For example, other rights such as publicity, privacy, or moral rights may limit how you use the material.




